Comment utiliser la version PHP de LAMPP par défaut

Si vous développez sous Linux et que votre environnement de développement utilise LAMPP (XAMPP), vous devez configurer votre terminal pour que ce dernier utilise la version de PHP de LAMPP par défaut.

En effet si vous tapez

php

dans votre terminal, ce n’est pas la version de php de LAMPP qui va être appelé mais la version brute d’apache.

# apt-get install php5-common libapache2-mod-php5 php5-cli
installation d'apache et php

Pour que votre terminal utilise la version PHP de LAMPP par défaut, il faut éditer le fichier .bashrc que vous pouvez trouver grâce à la commande

locate .bashrc

et insérer le code suivant à la fin du fichier :

PATH=/opt/lampp/bin:$PATH

Une fois que cette ligne a été rajouté, fermez et enregistrez.

tapez maintenant cette ligne de commande afin de mettre à jour le shell

source .bashrc

Vous pouvez maintenant utiliser la commande « php » dans votre terminal et se sera la bonne version qui sera appelée.